using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.\d+\.\d+\.\d+) ([a-zA-z0-9-]) ([a-zA-z0-9-]) (\[\d{2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) ""(GET [\/a-zA-Z0-9.-]+ HTTP\/1.1)"" \d{3} \d* ""([a-zA-z0-9-])"" ""([a-zA-z0-9\/. ;+\\():]+)"" ""([a-zA-z0-9-])""";
string input = @"66.249.69.58 - - [20/Nov/2015:03:54:09 -0500] ""GET /robots.txt HTTP/1.1"" 404 3652 ""-"" ""Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"" ""-""
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}