const regex = /(\d+\.\d+\.\d+\.\d+) ([a-zA-z0-9-]) ([a-zA-z0-9-]) (\[\d{2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) "(GET [\/a-zA-Z0-9.-]+ HTTP\/1.1)" \d{3} \d* "([a-zA-z0-9-])" "([a-zA-z0-9\/. ;+\\():]+)" "([a-zA-z0-9-])"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.\\d+\\.\\d+\\.\\d+) ([a-zA-z0-9-]) ([a-zA-z0-9-]) (\\[\\d{2}\\\/\\w{3}\\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} -\\d{4}\\]) "(GET [\\\/a-zA-Z0-9.-]+ HTTP\\\/1.1)" \\d{3} \\d* "([a-zA-z0-9-])" "([a-zA-z0-9\\\/. ;+\\\\():]+)" "([a-zA-z0-9-])"', '')
const str = `66.249.69.58 - - [20/Nov/2015:03:54:09 -0500] "GET /robots.txt HTTP/1.1" 404 3652 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" "-"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}