use strict;
my $str = '66.249.69.58 - - [20/Nov/2015:03:54:09 -0500] "GET /robots.txt HTTP/1.1" 404 3652 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" "-"
';
my $regex = qr/(\d+\.\d+\.\d+\.\d+) ([a-zA-z0-9-]) ([a-zA-z0-9-]) (\[\d{2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) "(GET [\/a-zA-Z0-9.-]+ HTTP\/1.1)" \d{3} \d* "([a-zA-z0-9-])" "([a-zA-z0-9\/. ;+\\():]+)" "([a-zA-z0-9-])"/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}