import re
regex = re.compile(r"(\d+\.\d+\.\d+\.\d+) ([a-zA-z0-9-]) ([a-zA-z0-9-]) (\[\d{2}\/\w{3}\/\d{4}:\d{2}:\d{2}:\d{2} -\d{4}\]) \"(GET [\/a-zA-Z0-9.-]+ HTTP\/1.1)\" \d{3} \d* \"([a-zA-z0-9-])\" \"([a-zA-z0-9\/. ;+\\():]+)\" \"([a-zA-z0-9-])\"")
test_str = ("66.249.69.58 - - [20/Nov/2015:03:54:09 -0500] \"GET /robots.txt HTTP/1.1\" 404 3652 \"-\" \"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\" \"-\"\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")