import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.\\d+\\.\\d+\\.\\d+) ([a-zA-z0-9-]) ([a-zA-z0-9-]) (\\[\\d{2}\\/\\w{3}\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} -\\d{4}\\]) \"(GET [\\/a-zA-Z0-9.-]+ HTTP\\/1.1)\" \\d{3} \\d* \"([a-zA-z0-9-])\" \"([a-zA-z0-9\\/. ;+\\\\():]+)\" \"([a-zA-z0-9-])\"";
final String string = "66.249.69.58 - - [20/Nov/2015:03:54:09 -0500] \"GET /robots.txt HTTP/1.1\" 404 3652 \"-\" \"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\" \"-\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}