using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[size=([0-9]{1,2})\](.*?)\[\/size\]";
string substitution = @"<span style=""font-size:$1pt"">$2</span>";
string input = @"[size=100pt;top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[size=12]We are safe, phew![/size]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}