re = /\[size=([0-9]{1,2})\](.*?)\[\/size\]/
str = '[size=100pt;top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[size=12]We are safe, phew![/size]'
subst = '<span style="font-size:$1pt">$2</span>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result