// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[size=([0-9]{1,2})\](.*?)\[\/size\]").unwrap();
let string = "[size=100pt;top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[size=12]We are safe, phew![/size]";
let substitution = "<span style=\"font-size:$1pt\">$2</span>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}