const regex = /\[size=([0-9]{1,2})\](.*?)\[\/size\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[size=([0-9]{1,2})\\](.*?)\\[\\\/size\\]', '')
const str = `[size=100pt;top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[size=12]We are safe, phew![/size]`;
const subst = `<span style="font-size:$1pt">$2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);