import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[size=([0-9]{1,2})\\](.*?)\\[\\/size\\]";
final String string = "[size=100pt;top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]\n\n"
+ "[size=12]We are safe, phew![/size]";
final String subst = "<span style=\"font-size:$1pt\">$2</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}