package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`,(?<host>\w+)$`)
var str = `Feb 15 10:44:32 test01pano.xxxxxx.com 1,2018/02/15 10:44:32,012501001035,SYSTEM,general,0,2018/02/15 10:44:23,,general,,0,0,general,informational,"FqdnRefresh job enqueued. Enqueue time=2018/02/15 10:44:23. JobId=13221. . Type: Full",6498771941074183103,0x8000000000000000,0,0,0,0,,deast02fw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}