import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?<host>\\w+)$";
final String string = "Feb 15 10:44:32 test01pano.xxxxxx.com 1,2018/02/15 10:44:32,012501001035,SYSTEM,general,0,2018/02/15 10:44:23,,general,,0,0,general,informational,\"FqdnRefresh job enqueued. Enqueue time=2018/02/15 10:44:23. JobId=13221. . Type: Full\",6498771941074183103,0x8000000000000000,0,0,0,0,,deast02fw";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}