const regex = /,(?<host>\w+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?<host>\\w+)$', 'g')
const str = `Feb 15 10:44:32 test01pano.xxxxxx.com 1,2018/02/15 10:44:32,012501001035,SYSTEM,general,0,2018/02/15 10:44:23,,general,,0,0,general,informational,"FqdnRefresh job enqueued. Enqueue time=2018/02/15 10:44:23. JobId=13221. . Type: Full",6498771941074183103,0x8000000000000000,0,0,0,0,,deast02fw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}