#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<YYYY>"
Local $sString = "-11.88" & @CRLF & _
"<0.012541>" & @CRLF & _
"-<3.14>" & @CRLF & _
"<-2.98>" & @CRLF & _
"" & @CRLF & _
"<1.23" & @CRLF & _
"<-abcdefg>" & @CRLF & _
"<MMM>" & @CRLF & _
"<YYYY>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")