$re = '/<YYYY>/m';
$str = '-11.88
<0.012541>
-<3.14>
<-2.98>
<1.23
<-abcdefg>
<MMM>
<YYYY>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);