import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<YYYY>";
final String string = "-11.88\n"
+ "<0.012541>\n"
+ "-<3.14>\n"
+ "<-2.98>\n\n"
+ "<1.23\n"
+ "<-abcdefg>\n"
+ "<MMM>\n"
+ "<YYYY>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}