using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<YYYY>";
string input = @"-11.88
<0.012541>
-<3.14>
<-2.98>
<1.23
<-abcdefg>
<MMM>
<YYYY>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}