const regex = new RegExp('<YYYY>', 'gm')
const str = `-11.88
<0.012541>
-<3.14>
<-2.98>
<1.23
<-abcdefg>
<MMM>
<YYYY>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}