#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ABC_A_CommunityRollover_Autocreate_Community\.[0-9-]+\.out"
Local $sString = "ABC_A_CommunityRollover_Autocreate_Community.12345678-1.out ABC_A_CommunityRollover_Autocreate_Community.88345678-1.out ABC_A_CommunityRollover_Autocreate_Community.99945678-1.out"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")