// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ABC_A_CommunityRollover_Autocreate_Community\.[0-9-]+\.out").unwrap();
let string = "ABC_A_CommunityRollover_Autocreate_Community.12345678-1.out ABC_A_CommunityRollover_Autocreate_Community.88345678-1.out ABC_A_CommunityRollover_Autocreate_Community.99945678-1.out";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}