use strict;
my $str = 'ABC_A_CommunityRollover_Autocreate_Community.12345678-1.out ABC_A_CommunityRollover_Autocreate_Community.88345678-1.out ABC_A_CommunityRollover_Autocreate_Community.99945678-1.out';
my $regex = qr/ABC_A_CommunityRollover_Autocreate_Community\.[0-9-]+\.out/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}