using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ABC_A_CommunityRollover_Autocreate_Community\.[0-9-]+\.out";
string input = @"ABC_A_CommunityRollover_Autocreate_Community.12345678-1.out ABC_A_CommunityRollover_Autocreate_Community.88345678-1.out ABC_A_CommunityRollover_Autocreate_Community.99945678-1.out";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}