using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9]+[-\/\s]?)*[a-z0-9]+\.?$";
string input = @"Mary Roe
Megasytems Inc
Suite 5A-1204
799 E DRAGRAM
TUCSON AZ 85705
USA";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}