const regex = /^([a-z0-9]+[-\/\s]?)*[a-z0-9]+\.?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9]+[-\\\/\\s]?)*[a-z0-9]+\\.?$', 'i')
const str = `Mary Roe
Megasytems Inc
Suite 5A-1204
799 E DRAGRAM
TUCSON AZ 85705
USA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}