re = /^([a-z0-9]+[-\/\s]?)*[a-z0-9]+\.?$/i
str = 'Mary Roe
Megasytems Inc
Suite 5A-1204
799 E DRAGRAM
TUCSON AZ 85705
USA'
# Print the match result
str.match(re) do |match|
puts match.to_s
end