import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z0-9]+[-\\/\\s]?)*[a-z0-9]+\\.?$";
final String string = "Mary Roe\n"
+ "Megasytems Inc\n"
+ "Suite 5A-1204\n"
+ "799 E DRAGRAM\n"
+ "TUCSON AZ 85705\n"
+ "USA";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}