$re = '/^([a-z0-9]+[-\/\s]?)*[a-z0-9]+\.?$/i';
$str = 'Mary Roe
Megasytems Inc
Suite 5A-1204
799 E DRAGRAM
TUCSON AZ 85705
USA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);