#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b\w+\b)[^\n]*?\1"
Local $sString = "test test test test" & @CRLF & _
"test ttestt test etestt" & @CRLF & _
"ttestt test " & @CRLF & _
"ttestt tttesttt" & @CRLF & _
"1test2 1test2 1test2 21test21" & @CRLF & _
"tetst tetst tetst" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")