import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\w+\\b)[^\\n]*?\\1";
final String string = "test test test test\n"
+ "test ttestt test etestt\n"
+ "ttestt test \n"
+ "ttestt tttesttt\n"
+ "1test2 1test2 1test2 21test21\n"
+ "tetst tetst tetst\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}