import re
regex = re.compile(r"(\b\w+\b)[^\n]*?\1", flags=re.MULTILINE)
test_str = ("test test test test\n"
"test ttestt test etestt\n"
"ttestt test \n"
"ttestt tttesttt\n"
"1test2 1test2 1test2 21test21\n"
"tetst tetst tetst\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")