re = /(\b\w+\b)[^\n]*?\1/m
str = 'test test test test
test ttestt test etestt
ttestt test
ttestt tttesttt
1test2 1test2 1test2 21test21
tetst tetst tetst
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end