using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+\b)[^\n]*?\1";
string input = @"test test test test
test ttestt test etestt
ttestt test
ttestt tttesttt
1test2 1test2 1test2 21test21
tetst tetst tetst
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}