#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)abc(?:(?!abc|xyz|123).)*123(?:(?!abc|xyz).)*xyz"
Local $sString = "abc 123 xyz" & @CRLF & _
"abc abc 123 xyz" & @CRLF & _
"abc text 123 xyz" & @CRLF & _
"abc text xyz xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")