re = /abc(?:(?!abc|xyz|123).)*123(?:(?!abc|xyz).)*xyz/
str = 'abc 123 xyz
abc abc 123 xyz
abc text 123 xyz
abc text xyz xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end