const regex = new RegExp('abc(?:(?!abc|xyz|123).)*123(?:(?!abc|xyz).)*xyz', 'gs')
const str = `abc 123 xyz
abc abc 123 xyz
abc text 123 xyz
abc text xyz xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}