$re = '/abc(?:(?!abc|xyz|123).)*123(?:(?!abc|xyz).)*xyz/s';
$str = 'abc 123 xyz
abc abc 123 xyz
abc text 123 xyz
abc text xyz xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);