using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc(?:(?!abc|xyz|123).)*123(?:(?!abc|xyz).)*xyz";
string input = @"abc 123 xyz
abc abc 123 xyz
abc text 123 xyz
abc text xyz xyz";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}