package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)REGEXP_LIKE(REPLACE(a.phone1,' ',''), '^(7)(\d*){9}$')`)
var str = `078787887
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}