const regex = new RegExp('REGEXP_LIKE(REPLACE(a.phone1,\\' \\',\\'\\'), \\'^(7)(\\d*){9}$\\')', 'mg')
const str = `078787887
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}