re = /REGEXP_LIKE(REPLACE(a.phone1,' ',''), '^(7)(\d*){9}$')/m
str = '078787887
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end