// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)REGEXP_LIKE(REPLACE(a.phone1,' ',''), '^(7)(\d*){9}$')").unwrap();
let string = "078787887
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}