$re = '@REGEXP_LIKE(REPLACE(a.phone1,\' \',\'\'), \'^(7)(\d*){9}$\')@m';
$str = '078787887
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);