import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w0-1P(?!.*--)[\\w-]*$";
final String string = "R0-1P-10-8--F--YH-\n"
+ "10-1Pabc--\n"
+ "10-1P-3E-Q-\n"
+ "D0-1P\n"
+ "D0-1P-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}