import re
regex = re.compile(r"^\w0-1P(?!.*--)[\w-]*$", flags=re.MULTILINE)
test_str = ("R0-1P-10-8--F--YH-\n"
"10-1Pabc--\n"
"10-1P-3E-Q-\n"
"D0-1P\n"
"D0-1P-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")