re = /^\w0-1P(?!.*--)[\w-]*$/m
str = 'R0-1P-10-8--F--YH-
10-1Pabc--
10-1P-3E-Q-
D0-1P
D0-1P-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end