#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\\(?<Year>\d\d\d\d)(?<Month>\d\d)\s(?<Series>.*)\sv(?<Volume>\d+)?\s(?<Number>\d{3,})\.cbr"
Local $sString = "H:\Comics\Marvel\CMC 1939-1949\CMC 1939 10-12\193910 Marvel Comics v1 001.cbr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")