re = /.*\\(?<Year>\d\d\d\d)(?<Month>\d\d)\s(?<Series>.*)\sv(?<Volume>\d+)?\s(?<Number>\d{3,})\.cbr/
str = 'H:\\Comics\\Marvel\\CMC 1939-1949\\CMC 1939 10-12\\193910 Marvel Comics v1 001.cbr'
# Print the match result
str.match(re) do |match|
puts match.to_s
end