use strict;
my $str = 'H:\\Comics\\Marvel\\CMC 1939-1949\\CMC 1939 10-12\\193910 Marvel Comics v1 001.cbr';
my $regex = qr/.*\\(?<Year>\d\d\d\d)(?<Month>\d\d)\s(?<Series>.*)\sv(?<Volume>\d+)?\s(?<Number>\d{3,})\.cbr/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}