using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\\(?<Year>\d\d\d\d)(?<Month>\d\d)\s(?<Series>.*)\sv(?<Volume>\d+)?\s(?<Number>\d{3,})\.cbr";
string input = @"H:\Comics\Marvel\CMC 1939-1949\CMC 1939 10-12\193910 Marvel Comics v1 001.cbr";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}