# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\S)\s+(?=\S\b)/$1/g;t' <<< "Text where s o m e parts are s h r u n k"